Results 1 to 8 of 8

Thread: Gizmo v4 electronic boost controller

  1. #1
    Guest
    Join Date
    Jul 2005
    Location
    Bedford
    Posts
    1,060
    Rides
    0

    Gizmo v4 electronic boost controller

    Evening all, my Gizzmo appears to have died... Started the car up today, heard the usual solenoid noise on ignition turn but no screen on the controller itself. Just blank... Have wiggled some wires at the back to no avail and disconnected reconnected but nothing. It's been installed since 2018 (by Horsham) and been faultless until now...

    Wondered if anyone had any ideas / knew of any companies that would service it if I sent it away? Would rather not have to go to Horsham as it's a 4 hour round trip. May post this on the FB site too as it's pretty tumbleweed around here of late...

  2. #2
    living on the edge p.nicholas's Avatar
    Join Date
    Jan 2002
    Location
    Essex meets
    Posts
    6,213
    Rides
    0
    I’m sure Horsham would fix it if you sent it to them

  3. #3
    Guest
    Join Date
    Jul 2005
    Location
    Bedford
    Posts
    1,060
    Rides
    0
    Cheers Paul, yes I’ve called them just waiting to get hold of Jez. Also have been in touch with Ray Carter at Gizzmo Melbourne Aus. and they will also repair it and send it back retaining all settings just charging for postage! So will see… seems balmy to send it to Aus but it’s very reasonable of them.

  4. #4
    living on the edge p.nicholas's Avatar
    Join Date
    Jan 2002
    Location
    Essex meets
    Posts
    6,213
    Rides
    0
    Is there an in-line fuse as that sounds more likely.

  5. #5
    Guest
    Join Date
    Jul 2005
    Location
    Bedford
    Posts
    1,060
    Rides
    0
    Well it's funny you should say that Paul, as today I had a messge from Ray at Gizzmo saying my controller checks out fine. So I'm thinking now it must be a wiring issue or fuse or even earth. Mine is wired to the ignition so on the first turn the Gizzmo would light up and be functioning. Could it be fuse related? I've checked all the fuses in the drivers footwell and under the bonnet, paying particular attention to the one's marked ignition. All look fine...

    Everything else appears to work fine... which has me scratching my head.
    Last edited by pb63; 05-04-2024 at 17:06.

  6. #6
    Guest
    Join Date
    Jul 2005
    Location
    Bedford
    Posts
    1,060
    Rides
    0
    Update: turns out it was the unit itself. Ray at Gizzmo was able to cannibalise some old stock to make my screen work again Top man

    Took the car out today and everything back to normal. All 270 ponies present and correct

    Have to say I was a tad weary of sending the unit off to Melbourne let alone receiving it back in tact but all is well. Have to give credit to Gizzmo Electronics and Ray Carter for taking the time to diagnose and repair my old unit effectively FOC as well. I just paid the carriage. He was excellent keeping me uptodate every step of the way. Dont get service like that from much bigger companies…

  7. #7
    living on the edge p.nicholas's Avatar
    Join Date
    Jan 2002
    Location
    Essex meets
    Posts
    6,213
    Rides
    0
    That’s great news

  8. #8
    Guest
    Join Date
    Jul 2006
    Location
    Dublin, Ireland
    Posts
    2,114
    Rides
    0
    Quote Originally Posted by pb63 View Post
    Update: turns out it was the unit itself. Ray at Gizzmo was able to cannibalise some old stock to make my screen work again Top man

    Took the car out today and everything back to normal. All 270 ponies present and correct

    Have to say I was a tad weary of sending the unit off to Melbourne let alone receiving it back in tact but all is well. Have to give credit to Gizzmo Electronics and Ray Carter for taking the time to diagnose and repair my old unit effectively FOC as well. I just paid the carriage. He was excellent keeping me uptodate every step of the way. Dont get service like that from much bigger companies…
    Excellent!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •