Results 1 to 13 of 13

Thread: Weird knock issue

  1. #1
    Guest d9lxw's Avatar
    Join Date
    Sep 2020
    Location
    Stockton-On-Tees
    Posts
    23
    Rides
    0

    Weird knock issue

    Hi, from a few weeks ago i noticed a knocking noise coming from my SR. It sounds like its coming from the bottom end around #4 but the bit that confuses me is that it comes and goes at idle depending on the day and will disappear altogether when i put revs on.
    Been driving it daily, sometimes belting it and its not got any worse

    What could be the cause? cheers

  2. #2
    Guest speedingmofa's Avatar
    Join Date
    Nov 2012
    Location
    the Netherlands
    Posts
    608
    Rides
    0
    Symptom sounds like those of the VTC going. Think the way to test it was to unplug the solenoid on the right side of the cyl head and see if the knocking disappears

  3. #3
    Guest d9lxw's Avatar
    Join Date
    Sep 2020
    Location
    Stockton-On-Tees
    Posts
    23
    Rides
    0
    Quote Originally Posted by speedingmofa View Post
    Symptom sounds like those of the VTC going. Think the way to test it was to unplug the solenoid on the right side of the cyl head and see if the knocking disappears
    Definitely not VCT, sound is coming from the back of the engine and Iíve just done the VCT

  4. #4
    Guest speedingmofa's Avatar
    Join Date
    Nov 2012
    Location
    the Netherlands
    Posts
    608
    Rides
    0
    Quote Originally Posted by d9lxw View Post
    Definitely not VCT, sound is coming from the back of the engine and I’ve just done the VCT
    Ah missed the part its coming from the rear. No idea then, normally if it's bad, it only gets worse with more rpm. Or else could be a lifter... more rpm, more oil pressure/volume?

  5. #5
    Guest d9lxw's Avatar
    Join Date
    Sep 2020
    Location
    Stockton-On-Tees
    Posts
    23
    Rides
    0
    Quote Originally Posted by speedingmofa View Post
    Ah missed the part its coming from the rear. No idea then, normally if it's bad, it only gets worse with more rpm. Or else could be a lifter... more rpm, more oil pressure/volume?
    To throw another spanner in the works, I did a test for piston slap (handbrake on, 1st gear and slowly lift the clutch to bog the engine) and the sound just disappeared again

  6. #6
    Guest jj205mi16's Avatar
    Join Date
    Sep 2009
    Location
    Ayrshire, Auchinleck
    Posts
    1,445
    Rides
    0
    Quote Originally Posted by d9lxw View Post
    To throw another spanner in the works, I did a test for piston slap (handbrake on, 1st gear and slowly lift the clutch to bog the engine) and the sound just disappeared again
    Flywheel isnít coming loose 😳

  7. #7
    Guest d9lxw's Avatar
    Join Date
    Sep 2020
    Location
    Stockton-On-Tees
    Posts
    23
    Rides
    0
    Quote Originally Posted by jj205mi16 View Post
    Flywheel isn’t coming loose ��
    That was a theory given the cars *questionable* past... reckon after a good few hundred miles it would have removed itself by now though

  8. #8
    Guest hooky's Avatar
    Join Date
    Apr 2011
    Location
    melksham
    Posts
    950
    Rides
    0
    Quote Originally Posted by jj205mi16 View Post
    Flywheel isn’t coming loose ��
    if its clutch/flywheel related, then putting pressure on the clutch pedal should change/eliminate the noise....

  9. #9
    Guest jj205mi16's Avatar
    Join Date
    Sep 2009
    Location
    Ayrshire, Auchinleck
    Posts
    1,445
    Rides
    0
    Agreed, number 4/ back of the block, if it was bearing related it would have died by now Iíd reckon and probably not intermittent.

    Iím just guessing, havenít heard it but Iíve heard a loose flywheel before, and a loose crank pulley.

    All we can do is guess without actually being there


    Sent from my iPhone using Tapatalk

  10. #10
    Guest d9lxw's Avatar
    Join Date
    Sep 2020
    Location
    Stockton-On-Tees
    Posts
    23
    Rides
    0
    Quote Originally Posted by hooky View Post
    if its clutch/flywheel related, then putting pressure on the clutch pedal should change/eliminate the noise....
    Depressing the clutch hasn’t done anything but that shouldn’t rule out the flywheel I think

  11. #11
    Guest d9lxw's Avatar
    Join Date
    Sep 2020
    Location
    Stockton-On-Tees
    Posts
    23
    Rides
    0
    Quote Originally Posted by jj205mi16 View Post
    Agreed, number 4/ back of the block, if it was bearing related it would have died by now I’d reckon and probably not intermittent.

    I’m just guessing, haven’t heard it but I’ve heard a loose flywheel before, and a loose crank pulley.

    All we can do is guess without actually being there


    Sent from my iPhone using Tapatalk
    Also my thoughts, initially thought it could be a bearing but with it going with changes in revs and it being intermittent means it’s unlikely. Not to mention the fact it hasn’t gotten worse in hundreds of miles, canny few not being easy on the engine. Just about confused everyone I’ve spoken to with this ��
    Last edited by d9lxw; 24-11-2020 at 20:20.

  12. #12
    Guest jj205mi16's Avatar
    Join Date
    Sep 2009
    Location
    Ayrshire, Auchinleck
    Posts
    1,445
    Rides
    0
    Drain the oil, do a compression test. If itís the engine you will know. If not, itís got to be transmission


    Sent from my iPhone using Tapatalk

  13. #13
    Guest d9lxw's Avatar
    Join Date
    Sep 2020
    Location
    Stockton-On-Tees
    Posts
    23
    Rides
    0
    Quote Originally Posted by jj205mi16 View Post
    Drain the oil, do a compression test. If it’s the engine you will know. If not, it’s got to be transmission


    Sent from my iPhone using Tapatalk
    Aye likely my next action, last time I did it 2 month ago I didn’t see any glitter in the oil, not sure if it was knocking then because I couldn’t hear much over the VCT...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •