Results 1 to 3 of 3

Thread: Spark plug tips for SR20DE

  1. #1
    Guest
    Join Date
    Jul 2016
    Location
    West Midlands
    Posts
    11
    Rides
    0

    Spark plug tips for SR20DE

    I'm finding the consensus online to be bkr7e for tuned turbo SR's bkr6e for standard turbo SR's and bkr5e for n/a

    I'm also seeing talk about bkr7/6/5e -11 aswell ?

    Car came with the iridium plugs in from Japan...about a month ago I put NGK bkr6e's on and the problem began, re-gapped them to .35 on someone's recommendation which seemed to help. Now I've just put the bkr5e's in and she just ran rough straight away...is this the ECU trying to re-jig things or wrong plugs or wrong gap ?

    Anyone have any ideas would be much appreciated
    Going to take the car to a garage tomorrow but would like to sort it myself really

    Cheers
    I'm running a stock n/a SR and since I've changed my plugs had some minor idle problems

    Sometimes no problem at all...occasionally when warm and sitting in traffic idle will drop and go to stall...sometimes when first started will do the same...Car runs drives and pulls fine! Just does this from time to time

  2. #2
    Member R3K1355's Avatar
    Join Date
    Nov 2006
    Location
    Yorkshire
    Posts
    12,053
    Rides
    0
    What gap? 0.35mm?? Thats ridiculously small.

  3. #3
    Guest
    Join Date
    Jun 2009
    Location
    walsall/tamworth
    Posts
    6,563
    Rides
    0
    probably a dirty idle valve.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •