Results 1 to 5 of 5

Thread: Ca18det wont hold boost?

  1. #1
    Guest
    Join Date
    Jan 2013
    Location
    Stockholm, Sweden
    Posts
    1
    Rides
    0

    Question Ca18det wont hold boost?

    Hi!

    I've got an odd problem and I'm stumped on what to do. Fully built engine with stage 3 and s15 bb turbo. been running 1,5bar previously without any problems.

    When driving under load the car will boost fine up to about 1 bar and then the boost vanishes but the car will continue to rev all the way up, but as if it has 40hp.
    If i let go off the throttle after the boost disappear it will do the same thing again, just higher up the revs. Driving the car under 1 bar it works fine.

    I've checked all the pipes and hoses and can't find any leaks. No bubbles.
    Tried removing the bypass valve incase it was malfunctioning, no difference.
    Tried removing the controller (manual screw type) still the same.
    Checked the coilpacks and plugs
    AFM works and is clean (z32)
    Removed fuel filter in case it was jammed
    redid the earth to engine, battery, fuel pump and harness

    I dont know what to try next really, has anyone had these problems before or got a good idea of what to look for?

    Thanks

  2. #2
    Guest jay1017's Avatar
    Join Date
    Dec 2016
    Location
    Dudley
    Posts
    467
    Rides
    0
    Itís a boost leak.

    Pressurize your piping to 2 bar and youíll see where its leaking from


    Sent from my iPhone using Tapatalk

  3. #3
    Member R3K1355's Avatar
    Join Date
    Nov 2006
    Location
    Yorkshire
    Posts
    11,929
    Rides
    0
    Boost leak, Vac leak or a broken actuator are most likely.

  4. #4
    Guest Adzsy's Avatar
    Join Date
    Jul 2005
    Location
    Huddersfield
    Posts
    1,376
    Rides
    0
    It sounds like your wastegate is opening on the turbo. To suddenly lose 1.5bar, and it not sound like a dump valve venting, it has to be more than just a loose pipework clip.
    Have you tried removing the vacuum line to the actuator? (Obviously be very careful you don't over boost) It might highlight something.

  5. #5
    Dorset & Hants Rep pointz's Avatar
    Join Date
    Sep 2009
    Location
    southampton
    Posts
    7,476
    Rides
    0
    1.5bar on a t28r??? Surely you're just blowing hot area at that pressure!
    1.4bar is about happy on a 2871r.

    Sorry off topic but you'll have bigger issues if you start detonating at 1.5bar

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •