Results 1 to 8 of 8

Thread: Universal washer tank

  1. #1
    Guest
    Join Date
    Apr 2012
    Location
    Northampton
    Posts
    741
    Rides
    0

    Universal washer tank

    Has anyone used anything like this before?

    Just want to see if they're any good.

    Kishan

  2. #2
    Member R3K1355's Avatar
    Join Date
    Nov 2006
    Location
    Yorkshire
    Posts
    11,930
    Rides
    0
    Like what?

  3. #3
    Guest
    Join Date
    Apr 2012
    Location
    Northampton
    Posts
    741
    Rides
    0

  4. #4
    Member R3K1355's Avatar
    Join Date
    Nov 2006
    Location
    Yorkshire
    Posts
    11,930
    Rides
    0
    Use the washer bag thing that people have been running for over a decade now.


    https://www.ebay.co.uk/itm/Windscree...wAAOSwpx9c3V8N

  5. #5
    Now with 400bhp....
    Join Date
    Aug 2007
    Location
    South west
    Posts
    35,842
    Rides
    1
    I’ve got one of those bottles. It works well enough. Just needs to be mounted well which mine isn’t :whack:
    South west Events and local meet info. See here


    My car on THRLL: http://thrll.com/car/1998-nissan-200sx-12410
    Chris Cooke Photograpy: https://www.facebook.com/ChrisCookePhotography
    1998 Nissan 200sx s14a , 2000 std 5 speed with nismo supercoppermix clutch bn6 Sapphire Blue

  6. #6
    Member hayell's Avatar
    Join Date
    Dec 2017
    Location
    Arundel
    Posts
    45
    Rides
    0
    Yeah it works, I have been using one in mine, the only problem is that in my experience the cheapy motors that come with them tend to be really weak

  7. #7
    Graphics Guru Davus200's Avatar
    Join Date
    Sep 2009
    Location
    South West
    Posts
    2,363
    Rides
    0
    I've got one of those mounted in the rear arch, been running it for years with no problem!

  8. #8
    Guest
    Join Date
    Apr 2012
    Location
    Northampton
    Posts
    741
    Rides
    0
    I ordered this.

    https://www.amazon.co.uk/TAKPART-Uni...73423121&psc=1

    Does anyone know what plug I need to solder it up to?

    I'm guessing it's the red and black loom with the plug on but I don't want to assume and get it wrong!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •