Results 1 to 14 of 14

Thread: Ps13 digital climate control. Only kicks out heat?

  1. #1
    Guest Jaymo_sx's Avatar
    Join Date
    Sep 2008
    Location
    Lincoln
    Posts
    4,009
    Rides
    0

    Ps13 digital climate control. Only kicks out heat?

    As above if I turn it on with any setting on any heat etc it's hot air. 18c blows hot air, 32c blows hot air. Is this a common problem and does anyone know what could be causing it?

    Thanks

  2. #2
    Yorkshire Rep CMR's Avatar
    Join Date
    Aug 2009
    Location
    Pontefract, Yorkshire
    Posts
    1,088
    Rides
    0

    Ps13 digital climate control. Only kicks out heat?

    Slide the passenger seat back, crawl or lie in the footwell and look up under the dash towards the centre column. There's a heater door with an arm actuator that opens or closes depending if you want hot or cold air. It can seize if not been used for awhile, mine needed a bit of plus gas on it when I first got the car and haven't had a problem since after cycling it hot and cold a few times to free it up.

    If it's seized you will probably hear it clicking when you turn the ignition on, be easier to hear if you can get someone to do the ignition whilst you are under the dash though
    Last edited by CMR; 25-06-2017 at 20:09.

  3. #3
    Guest Jaymo_sx's Avatar
    Join Date
    Sep 2008
    Location
    Lincoln
    Posts
    4,009
    Rides
    0
    Ah great! Sounds like that could be the issue. I'll check that out in the morning!

  4. #4
    Guest norfy's Avatar
    Join Date
    Jun 2008
    Location
    Ashford, Kent
    Posts
    1,283
    Rides
    0
    a more common issue is the ambient temp sensor being left unplugged or even missing, its the two pin sensor with the small hose that sits on the back of the gearstick surround. The climate control unit needs this to allow heat adjustment, if its not there the temperature will stay stuck on either hot or cold

  5. #5
    Guest Jaymo_sx's Avatar
    Join Date
    Sep 2008
    Location
    Lincoln
    Posts
    4,009
    Rides
    0
    Anyone have a pic of the sensor? I've got a 2 wire plug with ends cut off brown and blue into plug then both wires yellow out to cut off ends (guessing this is sensor as no polarity with same coloured wires?

  6. #6
    Guest Jaymo_sx's Avatar
    Join Date
    Sep 2008
    Location
    Lincoln
    Posts
    4,009
    Rides
    0

  7. #7
    Guest norfy's Avatar
    Join Date
    Jun 2008
    Location
    Ashford, Kent
    Posts
    1,283
    Rides
    0
    thats the sensor, or at least the cables. there should also be a 10mm id plastic hose in there although this isnt as important as the sensor itself.

  8. #8
    Guest Jaymo_sx's Avatar
    Join Date
    Sep 2008
    Location
    Lincoln
    Posts
    4,009
    Rides
    0
    Yeah found the corrugated tube thing. Runs round to the heater box behind glove box?

    Any idea where I would be able to find a sensor? Kind of sucks only getting hot air in summer, reminds me of my janky old UK s13 which had engine Temp issues haha

  9. #9
    Guest norfy's Avatar
    Join Date
    Jun 2008
    Location
    Ashford, Kent
    Posts
    1,283
    Rides
    0
    youd need a sensor from a 180 or ps13, i believe there are some uk ones also. gotta be someone breaking one

  10. #10
    Guest Jaymo_sx's Avatar
    Join Date
    Sep 2008
    Location
    Lincoln
    Posts
    4,009
    Rides
    0
    Do you have one? Could you measure the thermistor resistance for me and tell me what temp it was at that resistance?

  11. #11
    Guest norfy's Avatar
    Join Date
    Jun 2008
    Location
    Ashford, Kent
    Posts
    1,283
    Rides
    0
    Ill pull one out of one of my cars and have a measure

  12. #12
    Guest Jaymo_sx's Avatar
    Join Date
    Sep 2008
    Location
    Lincoln
    Posts
    4,009
    Rides
    0
    Quote Originally Posted by norfy View Post
    Ill pull one out of one of my cars and have a measure
    Thanks man ��

  13. #13
    Guest Jaymo_sx's Avatar
    Join Date
    Sep 2008
    Location
    Lincoln
    Posts
    4,009
    Rides
    0
    Any joy norfy?

  14. #14
    Guest norfy's Avatar
    Join Date
    Jun 2008
    Location
    Ashford, Kent
    Posts
    1,283
    Rides
    0
    Quote Originally Posted by Jaymo_sx View Post
    Any joy norfy?
    Apologies, kept forgetting :/

    Anyway. On my car at 18*c I'm getting 2.456 kOhm

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •