Results 1 to 2 of 2

Thread: Ignition will not turn off / Weak spark / Non starter....?????

  1. #1
    Guest Adzsy's Avatar
    Join Date
    Jul 2005
    Location
    Huddersfield
    Posts
    1,377
    Rides
    0

    Ignition will not turn off / Weak spark / Non starter....?????

    This project has challenged me like no other, so here is my latest problem that I just cannot resolve.

    For back ground I have put a CA18DET in my RA23 celica. All wiring of the F8 and F10 connectors is correct, and it worked 'ok' for a while.

    When I turn the ignition on it all lights up and ECU turns on. When I turn the ignition off again nothing turns off unless I unplug the coilpack harness or the ignition amplifier.

    I have changed the ignition amplifier (power transistor) for another with no change.

    The ECCS relay and coilpack relay stay on unless I unplug either then the other will turn off.

    It feels like an earthing problem but I have checked all my earths and all seems fine.

    I have gone over all my wiring a dozen times and can't see anything wrong.

    I keep coming back to the power transistor, I have checked two of them according to the workshop manual but get weird results on both. I have attached an image to show what I should get and what I do get. I am no electrician so can't make head nor tail of the readings.

    Can anyone help?



  2. #2
    Guest Adzsy's Avatar
    Join Date
    Jul 2005
    Location
    Huddersfield
    Posts
    1,377
    Rides
    0
    Solved! Simple, I connected the resistor connection to the transistor and vice versa upon reassembly!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •