Page 6 of 6 FirstFirst ... 456
Results 101 to 117 of 117

Thread: my first nissan s13 project

  1. #101
    Guest
    Join Date
    Mar 2004
    Location
    Helston, West Cornwall
    Posts
    24,447
    Rides
    0
    How many miles do they have on them ?

    Coilies don't tend to last as long as OEM struts. Some are cream-crackered after 10K miles.

  2. #102
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    Now that I couldn't say. they was on the car when I brought it. I'm just gonna have to get some cheap ones next month when I get paid because the car gets so unsettled

  3. #103
    Guest
    Join Date
    Mar 2004
    Location
    Helston, West Cornwall
    Posts
    24,447
    Rides
    0
    Push down hard and quickly on one corner of the car and release and see what happens. Repeat for each corner.

    If it won't go down except slowly and comes up slowly then you have too much damping so back off the adjuster.

    If it bounces quickly 3-4 times before settling then you don't have enough damping. If you have it on fully hard then they're shot. It won't do any harm to adjust them completely the other way. If they are no different, then they are probably shot.

    If it goes down and comes back up once, they're working so look for another problem.

    If you can't push it down at all, the springs are too hard and you need new shocks with softer springs.

    Its also possible that the rear subby bushes as so shot or the wheels are so far out of alignment that its adversely affecting the handling
    Last edited by Jonny Wilkinson; 23-09-2015 at 12:48.

  4. #104
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    When I puchased down on the corners it goes down fast and springs straight back up on all corners. When I go over speed humps the car rocks like a Mexican wave from front to back. I would say they are pretty shot hahaa. I'm just gonna have to wait till next month and pay out for ebay specials to get me by I think unless I can pick a used pair up for about 350 so I will keep an eye out on sale threads next month

  5. #105
    Guest
    Join Date
    Mar 2004
    Location
    Helston, West Cornwall
    Posts
    24,447
    Rides
    0
    If they are that bad, try adjusting them all the way the other way. They can't get worse than "not working"

  6. #106
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    I've decided to order some new mono pro's on finance :s got fed up with bouncing around like a ball in a mini game machine. 3 days they will be in my possession so will be interesting fitting these in the cold hahaa

  7. #107
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    so its been a while and thought a quick update is in order

    so my monopro's arrived and within a couple of weeks later I fitted and set them up. its amazing how much of a difference there was, the whole car just felt so planted to the road





    here is one of my coilovers side by side with a new one



    I then got fed up of the dull dash lights so I replaced all of them with leds.



    looks soo much better and easier to see

    ive ordered some conversion lines from apex to fit some s14a brake calipers up front to go with new 5 stud setup with new discs and pads too. they also sent me loads of stickers too




    this will all be fitted at the weekend along with my diff being welded and I have my drift ticket for santa pod this Wednesday really cannot wait



    more to come after the weekend guys

  8. #108
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    sorry if the photos are too big, I'm having to now use imgur to share my photos because photobucket wont let me log in and when I can all my new uploads fail

  9. #109
    Guest
    Join Date
    Oct 2014
    Location
    Near Brighton
    Posts
    341
    Rides
    0
    Nice to see some progress. Think you've inspired me to do the LED dash conversiion. Was wondering if they might be a little off putting/too bright? Are your old shocks HSDs too?

  10. #110
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    Quote Originally Posted by shikari chaos View Post
    Nice to see some progress. Think you've inspired me to do the LED dash conversiion. Was wondering if they might be a little off putting/too bright? Are your old shocks HSDs too?
    I thought the leds might be too bright too but I found out there is a rocker switch to the right side of the steering column. It adjusts the dashes brightness when held. It has a picture of a light bulb with a bracket that curves over it. I thought is was something to do with headlights till I looked it up.

    My old shocks were hsd's monopro's too they was that old you could see the difference between the two. The dampness adjuster on the old Was at the top and the new ones at the bottom.

  11. #111
    Guest
    Join Date
    Mar 2004
    Location
    Helston, West Cornwall
    Posts
    24,447
    Rides
    0
    Quote Originally Posted by shikari chaos View Post
    Nice to see some progress. Think you've inspired me to do the LED dash conversiion. Was wondering if they might be a little off putting/too bright? Are your old shocks HSDs too?
    Before you do the LED conversion, twiddle with that knob as its possible to have the dash quite bright with the regular bulbs if the wiring is healthy

    I have mine turned about 3/4 up from fully down to have them the right brightness for me.

    Soggy, Do you have any pics of the car and how it sits now its on the new shocks ?

  12. #112
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    I've not got any recent pics after the new coilovers have been fitted but I'm going 5 stud tomorrow if all goes well and I will take loads of photos then

  13. #113
    Guest
    Join Date
    Mar 2004
    Location
    Helston, West Cornwall
    Posts
    24,447
    Rides
    0
    Look forward to it.

  14. #114
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    So on the 27th of Jan I went santa pod for my first drift day and I loved it. Spent the whole day doing donuts and trying to do figure of 8's which I managed towards the end of the day... the car got me there and back but it's a little worse for wear now









    Not too bad looking underneath the car with the new sills. First proper pictures with it in the air.

    The only thing now is before the drift day the head has a suspected crack in it after I found oil in the radiator and when the car was started it would instantly pressurise the water system. We didn't have time to take the head off at the garage or I would of missed my drift day which was unacceptable. so we left it and went skidding anyway hahaa

    Sent from my SM-G925F using Tapatalk

  15. #115
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0






    As much as I would like to say that's tyre smoke the sad part is, it's not. that is some of the 8ltr's of oil I burned that day. So a steady drive home and a very unhealthy s13 parked on the driveway I set plans to start the project again. So now my local garage are taking a delivery of a complete 68k miles sr20 and everything I need to drop it all in my s13. I just need a loom now that I'm getting from wiring specialties next month.

    Sent from my SM-G925F using Tapatalk

  16. #116
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    So engine number 3 turned up yesterday. I've been on tesco's tinned food for three months to afford it. The wiring specialties harness will be on order next month also.



    Sent from my SM-G925F using Tapatalk

  17. #117
    Guest
    Join Date
    Jun 2014
    Location
    rugby
    Posts
    216
    Rides
    0
    so thought I would do a quick update been as its been a while a good 6 months pretty much. not a lot has changed but this is what you guys missed

    my wiring specialties harness turned up


    then I set a date for getting the old ca18 out the car and the new sr20 in, which we all know dates and deadlines never go to plan so what I had in mind was a good solid weekend ended up taking two weekends but we done it






    we had to cut the abs bracket to fit the sr20 engine in but then even that wasn't enough so we connected everything up and gave it a good old test run before fitting the bonnet and front bumper


    then we dropped the coolant and put some more in.

    then she ran fine for a good few months I guess it was the honeymoon period hahaa. then I blown 2 fuses and a 12v feed to the engine bay fuse box gave up somewhere in the wiring under the drivers side wing :'( then the turbo started smoking when on boost. so I took the intake pipe off and seen oil in there.

    so the car has been off the road for this month while I did the abs delete, replaced the manifold with a thicker 3mm one. the old was cracked and I couldn't weld it up, my other turbo will be rebuilt next week. so that's where I am for now....

    to be continued

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •